PSCX on XP x64

Topics: User Forum
Dec 30, 2006 at 10:14 PM
Has anybody managed to install PSCX on XP x64? When I run PowerShell, I get the errors shown below but the 32-bit version of PowerShell seems to work fine.

Why does the processor platform make a difference to PowerShell when it all sits on top of the processor independent .NET framework?


Windows PowerShell
Copyright (C) 2006 Microsoft Corporation. All rights reserved.

Add-PSSnapin : No Windows PowerShell Snap-ins are available for version 1.
At \\XXX\My Documents\XXX\WindowsPowerShell\profile.ps1:38 char:13
+ Add-PSSnapin <<<< Pscx
Transcript started, output file is \\XXX\My Documents\XXX\WindowsPowerShell\Transcripts\20061230.222041.1628.txt
C:\Documents and Settings\XXX
1>
Coordinator
Dec 31, 2006 at 12:39 AM
That's a bummer. I wasn't aware of this issue (don't have a 64 bit machine) but I guess the PowerShell team ran into issues getting snapins to work in 64 bit windows. It might be worth asking about on the microsoft.public.windows.powershell newsgroup.
Developer
Jan 1, 2007 at 2:46 PM
It seems there is a problem in the installation routine.
http://msdn2.microsoft.com/en-us/library/ms714644.aspx
Jan 2, 2007 at 4:35 PM
I've just posted on this issue on my blog: http://mark-sheppard.spaces.live.com/Blog/cns!1905A40C83BF050F!151.entry
Additionally, I've created a new issue for this in the Issue Tracker (I didn't think to check the forums first).

You'll be able to get it working on an x64 build by running the following two commands:
C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\InstallUtil.exe "C:\Program Files (x86)\PowerShell Community Extensions\InstallerCustomAction.dll"

C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\InstallUtil.exe "C:\Program Files (x86)\PowerShell Community Extensions\pscx.dll"
Jan 23, 2007 at 12:47 AM
"Just keep reading..." that should be my mantra as I troll through any BBS looking for a solution. Thanks this worked great!