Drop 1.1.1 is getting close

Topics: Developer Forum
Coordinator
Apr 29, 2007 at 11:59 PM
The last two work items that need to be addressed are:

  • Interrupting Write-* archive cmdlets leaves truncated files
  • Format-custom hanging with PSCX installed on certain commands.

I updated the installer to register the PSCX snapin in the PostInstall.cmd file since the VS Setup created installer does not seems to want to do this on an upgrade.
Developer
May 5, 2007 at 7:34 PM
I'll get onto the write-* archive problem asap.

- Ois
Developer
May 8, 2007 at 2:07 PM
I was testing out some maml.xslt tweaks and decided to run the setup for 1.1.1 :

"IMPORTANT: You will get an error on install if you have not uninstalled all previous versions of PSCX before installing version 1.1.1."

Is this still relevant?
Coordinator
May 9, 2007 at 8:34 PM
No, not for 1.1.1. I'll try to remove it tonight.
Coordinator
May 10, 2007 at 5:19 AM
OK, I removed that message.
Developer
Jun 2, 2007 at 3:18 PM
Zip fixes done, plus one or two other tweaks; so if you're happy with your format-* fix with that enumeration var, I guess we're nearly there. Let me know when the setup proj is done and I'll put it through its paces...
Coordinator
Jun 2, 2007 at 8:02 PM
Cool. That leaves just the FormatEnumerationLimit issue. I think perhaps that I will comment out that line in the profile with some verbiage of what it does and what problems you might run into if you uncomment it. I'm out of town visiting relatives on my wife's side. I'll get back late Sunday so let's shoot for a release by Friday if possible. The setup BTW is ready to go AFAIK. We primarily need to test installling over 1.1 and fresh and making sure the help built correctly.
Coordinator
Jun 5, 2007 at 5:43 AM
OK all my issues are now resolved and I've done a bit of testing on my XP SP2 VPC. I also have a 32 bit Vista image I plan to test on. Does anybody have an x64 Vista image they can test on? Oh yeah, Oisin, I assigned you a minor issue - Get-ExportedType help doesn't have a synopsis.
Developer
Jun 8, 2007 at 8:18 PM

rkeithhill wrote:
OK all my issues are now resolved and I've done a bit of testing on my XP SP2 VPC. I also have a 32 bit Vista image I plan to test on. Does anybody have an x64 Vista image they can test on? Oh yeah, Oisin, I assigned you a minor issue - Get-ExportedType help doesn't have a synopsis.


closed with #23455 and merged to trunk.